• caloianumarian
    April 26, 2015 at 6:20 pm #107265

    After update wordpress this error occurred:
    Fatal error: Cannot redeclare get_avatar_url() (previously declared in /home/snagovimobiliare/public_html/wp-includes/link-template.php:3414) in /home/snagovimobiliare/public_html/wp-content/themes/wpestate/libs/shortcodes.php on line 741

    what can i do?

    Thanks!

    mag07
    April 26, 2015 at 11:51 pm #107281

    Same issue. Ended up removing the following from the shortcodes.php –

    function get_avatar_url($get_avatar) {
    preg_match(“/src='(.*?)’/i”, $get_avatar, $matches);
    return $matches[1];
    }

    just to make the site work temporarily. Not sure what is affected atm but the site works.

    Would appreciate a reply. 4.2 update addresses a vulnerability among other things and as such is a critical update.

    Thanks

    caloianumarian
    April 27, 2015 at 5:08 am #107292

    I removed the code and the site is online now

    Thanks!

    Camelia Support Team - WP Estate
    May 5, 2015 at 1:10 pm #107903

    Hi,
    Please see my reply
    This issue was fixed on last version of WP Estate.
    The last theme version can be downloaded from Theme Forest – Your buyer Account – Downloads menu.

    Just to be sure you didn’t add any language file in wpestate/languages and you not forget to save before you update via admin, do this:

    a. Login via FTP and rename previous theme from wpestate to wpestate_old

    b. Then via wp-admin – themes – add new wpestate.zip from yesterday update and activate. That should be all.

    Next – if you had any language changes or perhaps other changes you can copy from wpestate_old backup to new wpestate folder.

    Please read the update notes carefully

    – get_avatar_url() replaced with wpestate_get_avatar_url() in

    bloglisting.php line 18

    bloglisting_search.php line 15

    functions.php line 606

    shortcodes.php line 671 and 738

    single.php line 59

    – Sidebar plugin update included in the theme to be compatible with 4.2 requirements. Change made is below:

    multiple_sidebar_plugins.php

    added ‘id’=>sanitize_title($sidebar), at line 60

    IMPORTANT NOTE:This is a third party plugin, but we had to make it compatible with WordPress 4.2 standards. Because of that – all custom sidebars added before this update in SIDEBARS – ADD NEW – will need to be populated with WIDGETS again from Appearance – Widgets. Then all pages with custom sidebars will have to be saved again.

    – Rev Slider update to 4.6.9

    NOTE: export your revolution sliders before you update – for backup. For some clients – the update deleted their SLIDERS.

    – map-search-form.php
    Thank you,
    Camelia

You must be logged in to reply to this topic.

Contact Us

We're not around right now. But you can send us an email and we'll get back to you, asap.