Your address will show here +12 34 56 78

Home Forums WP ESTATE – Real Estate WordPress Theme FORUM Disable responsive site

This topic contains 11 replies, has 2 voices, and was last updated by  Alex 3 years, 8 months ago.

  • Author
    Posts
  • #17857

    Alex

    Hi Anna,

    Having quizzed you in the comments I bought the theme a couple of days ago and am really happy with it! You’ve really engineered it so well. Compared to most other themes I’ve used its a pleasure to work with.

    I’d like to disable the responsive elements of the site if possible. My target audience is unlikely to use it on a mobile and elements I have changed will not work as well on a mobile layout.

    Is there some css I could enter/remove to achieve this?

    Any help appreciated! Thanks

  • #17887

    Anna
    Keymaster

    Hi Alex,

    This is such great news 🙂 Thank you!

    To disable Responsive, rename my_media.css to my_mediax.css (just an example) Should be enough.

    Let me know if you need more help.

    Thank you!
    Anna

  • #19836

    Ksearch

    Hi Anna, just tried renaming my_media.css and commented the “my_media” line in Functions.php but some elements still try to change its distribution when the browser window gets smaller (top menu, sliders and content).

    Is there another file that has to be modified to disable this behaviour?

    Thanks!

    K.

  • #19877

    crerem

    Hi,
    My_media css is the only file that is responsible with the responsive. So if you delete that and still not work make sure is not caching.

    If the problem persist -plese comeback with a link and more details.

    thanks

  • #19889

    Alex

    Hi Anna and Crerem,

    I’m also having the same issue as Ksearch. I’ve disabled the My_media.css file by renaming it and this has clearly had an effect on the site as a mobile version now no longer loads. However rather than the page staying at a fixed size on the screen the menu bar is narrowing (but not the link bar which is now staying at a fixed size). The footer also narrows.

    If you have any other ideas on how to completely fix the size of the layout so it appears the same on all screens that would be appreciated.

    By the way, your responsive styling works well and appreciate the effort that must have gone into it but for my purposes (and somewhat complex page layouts) keeping things fixed is just easier!

    Thanks for your help

  • #19911

    Ksearch

    Hi Crerem,

    My site isn’t uploaded yet (still running it locally for development work) so, I can’t share an URL to check the issue.

    I run some tests and it doesn’t look like a CSS cache issue, for example, the post content got “fixed” by adding “.row {min-width: 940px;}” in custom CSS, but I haven’t had luck with the menu related classes. Would you help me with some tip about it? Thanks!

    K.

  • #19914

    crerem

    Hello,
    Please send me a live link – it almost impossible to help you without seeing what is actually happening.
    Looking over the js files – there are some actions that are performed when the screen is less than 960 px wide – but i need to see a live example before giving directions
    Thanks

  • #19961

    Alex

    Hi Crerem,

    Link for my test site is:

    http://agencymaison.staging.wpengine.com/

    I’ve disabled the My_media.css file by renaming it.

    Any thoughts appreciated.

    Cheers,

    alex

  • #20029

    crerem

    Hello,

    First: on http://agencymaison.staging.wpengine.com/ – the revolution slider is set to responsive and this make the things a little messy – disable the responsive pls

    Second : open header.php and remove this line
    <meta name=”viewport” content=”width=device-width, initial-scale=1, maximum-scale=1″ />

    There are other steps but let’s do these 2 first.

    Thanks

  • #20046

    Alex

    Hi,

    Ok, done those two things and have also disabled the media_css by renaming it.

    I will await further instructions!

    Thanks for your help with this.

    Alex

  • #20065

    crerem

    Ok,
    add these at the end of the style.css

    .header_control {
    min-width:160px;
    }

    #access{
    height:600px;
    }

    .header_social{
    width:0px;
    }

    html, body {
    height: 100%;
    width: 100%;
    min-width: 1200px;
    }

    After this the first page should looks the way you want. Btw, why do you want to disable responsive ? It will not look nice on smartphones or smaller tablets

  • #20370

    Alex

    Hi,

    Thanks for getting back to me with those instructions. I’m now managing to achieve more of the look I’m after. I’ve quite heavily modified the layout of some pages and this makes things go funny with the standard media queries. I need to re-write some of those but in the meantime this is a good fix.

    Appreciate your help.

    Cheers

You must be logged in to reply to this topic.