Your address will show here +12 34 56 78

Home Forums WP ESTATE – Real Estate WordPress Theme FORUM Lists not functioning in Tabs

This topic contains 6 replies, has 2 voices, and was last updated by  Anna 3 years, 4 months ago.

  • Author
    Posts
  • #39342

    Tony

    Hi Anna,
    I decided to make a new thread for the Tabs problem.
    Three things.
    (1) Main problem… Lists of any kind don’t seem to work in Tabs.
    (2) Secondary… I get a blue line through 2 of 3 tab content areas… but you stated you didn’t repeat that issue in your own template. Not sure why, my testing in 3 browsers has same problems 1-2.
    (3) Content posted after a tab set appears to the right of the tabs instead of below.
    Please check here:
    http://www.showcasevr.com/home/bugs/tabs-list-problem

    image

    
    This page shows numerous issues with Tab content.
    
    When using Lists, Bullet Lists, and Numbered Lists inside a Tab environment:
    
    Lists do not work
    Lines are formed inside the content area
    Content posted after the tab set is moved to a right side alignment with the Tab Set instead of below the Tabs.
     
    
    [tabs elements="Tab Name 1,Tab Name 2,Tab Name 3"]
    
    [tab id=tab1]
    
    [check-list title="List Title" type="type1 to type 10"]
    
    List element #1
    List element #2
    List element #3
    [/check-list]
    
    [/tab]
    
    [tab id=tab2]
    
    list item 1
    list item 2
    list item 3
    list item 4
    [/tab]
    
    [tab id=tab3]
    
    item one
    item two
    item three
    item four
    [/tab]
    
    [/tabs]
    
     
    
    Hi, I'm content after the tabs set. I should be below the tab set. Where Am I?
    

    Thanks
    Tony

  • #39532

    Anna
    Keymaster

    Hi Tony,

    This is being reviewed. One of my colleagues will post an update as soon as there is a solution. We will work on your page in browser preview so please don’t delete that.

    Thank you!
    Anna

  • #39685

    crerem

    Hello,
    Try adding into custom css this rule

    .tabs .checklit li{
    clear:both;
    }

    Let me know if it works so we can add it to the next version.
    Thanks

  • #40507

    Tony

    OK,
    So Sorry,
    I have had trouble with getting a clean setup that includes the demo content. I ended up starting over.
    So… per crerem’s post above, I tried the new css. It does not help.

    Here is the new link: http://www.showcasevr.com/?page_id=6419
    or
    Visit http://www.showcasevr.com and select “Features/Shortcodes/Tab Test”

    1) Lists do not work inside Tabs
    2) Content after Tabs moves to right instead of below tabs… this happens with or without having a list inside the tab set.

  • #40515

    Anna
    Keymaster

    Hi Tony,

    Can you email me the exact shortcode ? If that CSS didn’t do the trick, then we have to retest. Send me the shortcode in TEXT mode, to make sure all HTML is there. It may have been one reason for my last tests.

    Thank you!
    Anna

  • #40541

    Tony

    Hi Anna,

    I’m not modifying anything… the shortcodes are created when using the icons from the Add New Page templates

    
    [tabs elements="Tab Name 1,Tab Name 2,Tab Name 3 etc.."][tab id=tab1]Tab Content 1[/tab][tab id=tab2]Tab Content 2[/tab][tab id=tab3]Tab Content 3[/tab][/tabs]
    

    Then, I simply add content after the tabs and it indents to the right of the tabs.

    Also, I grab a bulleted list, numbered list, or list from the icons, insert into the 3 tabs which are generated by default, and none of the lists work. They just layout as if a single line of text inside a tab.

  • #40625

    Anna
    Keymaster

    Got it, Tony. Thank you. We’re working on a new theme version and we are reviewing these combinations as well to make sure they align. Thank you for the help and patience.

    Anna

You must be logged in to reply to this topic.